Kevin Bauer The rants and ramblings of Kevin Bauer.

14Aug/110

PHPMyAdmin Installation

Several friends of mine who enjoy running LAMP (Or WAMP) tend to ask for help installing PHPMyAdmin. It's a great administration and development tools that is incredibly easy to install.

How To:
There only major requirements for the latest PHPMyAdmin builds is PHP5.2+ and MySQL 5. To check compatability, upload a PHPINFO file. As long as your PHP version (Should be at the very TOP of the page) is 5.2 or higher, and your MySQL version (found under the MySQL tab as "Client API version" is 5 or higher, you should be ready to install it.

To Create a PHPINFO file, add the following to a file, and upload it to your server.

PhpMyAdmin is just a normal PHP script used to manipulate MySQL databases. To install it simply download the latest release with your preferred archive type here, and extract & upload to your server. If you wish to use only your MySQL database login, all you will need to edit is the config.sample.inc.php and enter a blowfish secret. This is used as a salt for cookie-based authentication. Once you're done entering some random text, save this file as config.inc.php and your PHPMyAdmin should now be functional!

Filed under: How To's Leave a comment
Comments (0) Trackbacks (0)

No comments yet.


Leave a comment

No trackbacks yet.